HDU 1025 Constructing Roads In JGShining's Kingdom(二维LIS)

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23467    Accepted Submission(s): 6710

Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 
Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 
Output
For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 
 
Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
 
Sample Output
Case 1: My king, at most 1 road can be built.
 
 
Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.

题目链接:HDU 1025

懂了求一般一维LIS的一般方法就可以做了,只是把lowerbound改一下和排序方式改一下……WA几次发现不可以用自己写的排序比较来二分,因为一旦遇到一个l<t.l就会返回true,然而二分是找一个位置不仅使得l<t.l且显然要r<t.r,然后自己写了个自定义函数作为lowerbound参数就过了

代码:

#include<stdio.h>
#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=500010;
struct info
{
    int l,r;
    bool operator<(const info &t)const
    {
        if(l!=t.l)
            return l<t.l;
        return r<t.r;
    }
};
info node[N];
info d[N];
bool check(const info &a,const info &b)//这里要重写,跟结构体里的还是有区别的
{
    return a.l<b.l&&a.r<b.r;
}
void init()
{
    CLR(node,0);
    CLR(d,0);
}
int main(void)
{
    int tcase=0,n,i;
    while (~scanf("%d",&n))
    {
        init();
        for (i=1; i<=n; ++i)
        {
            scanf("%d%d",&node[i].l,&node[i].r);
        }
        sort(node+1,node+1+n);

        int len=1;
        d[len]=node[len];
        for (i=2; i<=n; ++i)
        {
            if(d[len].l<node[i].l&&d[len].r<node[i].r)
                d[++len]=node[i];
            else
            {
                int pos=lower_bound(d,d+len,node[i],check)-d;
                d[pos]=node[i];
            }
        }
        printf("Case %d:
My king, at most %d road%s can be built.

",++tcase,len,len>1?"s":"");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/Blackops/p/5856137.html