[洛谷P2852] [USACO06DEC]牛奶模式Milk Patterns

洛谷题目链接:[USACO06DEC]牛奶模式Milk Patterns

题目描述

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

农夫John发现他的奶牛产奶的质量一直在变动。经过细致的调查,他发现:虽然他不能预见明天产奶的质量,但连续的若干天的质量有很多重叠。我们称之为一个“模式”。 John的牛奶按质量可以被赋予一个0到1000000之间的数。并且John记录了N(1<=N<=20000)天的牛奶质量值。他想知道最长的出现了至少K(2<=K<=N)次的模式的长度。比如1 2 3 2 3 2 3 1 中 2 3 2 3出现了两次。当K=2时,这个长度为4。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and K

Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

输出格式:

Line 1: One integer, the length of the longest pattern which occurs at least K times

输入输出样例

输入样例#1:

8 2
1
2
3
2
3
2
3
1

输出样例#1:

4

题意: 找最少出现(k)次的子串的最大长度.

题解: 根据贪心策略,子串变长答案不会减小,所以可以看做是求(k)个后缀的(LCP).因为要求(LCP)的最大值,而(LCP(suffix(sa[i]),suffix(sa[j]))=min{height[k]}(i<j,kin[i,j])),显然当这(k)个后缀在排名上连续的时候可以取得最小值.因为若排名不连续,那么涵盖的取最小值的范围一定会变大,而当取值范围变大最小值只会变小.所以这个贪心是正确的.

那么我们就直接后缀数组求出(height)数组,然后枚举排名一遍单调队列扫一下长度为(k-1)的滑动窗口中的最小值,并对这些最小值取个(max)就是答案了.

为什么滑动窗口的长度是(k-1)呢?因为(height[i]=lcp(suffix(sa[i]),suffix(sa[i-1]))),所以(k-1)(height)就可以计算出(k)个后缀的(LCP)的最小值啦.

#include<bits/stdc++.h>
using namespace std;
const int N = 40000+5;
const int inf = 0x3f3f3f3f;

int n, m, k, sa[N], rk[N], buk[N], sec[N], q[N], a[N], height[N], h, t, ans;

void rsort(){
    for(int i = 0; i <= m; i++) buk[i] = 0;
    for(int i = 1; i <= n; i++) buk[rk[i]]++;
    for(int i = 1; i <= m; i++) buk[i] += buk[i-1];
    for(int i = n; i >= 1; i--) sa[buk[rk[sec[i]]]--] = sec[i];
}

void SuffixArray(){
    for(int i = 1; i <= n; i++) rk[i] = a[i], sec[i] = i;
    m = n; rsort(); int num = 0;
    for(int l = 1; l <= n && num < n; l <<= 1){
        num = 0;
        for(int i = 1; i <= l; i++) sec[++num] = n-l+i;
        for(int i = 1; i <= n; i++) if(sa[i] > l) sec[++num] = sa[i]-l;
        rsort(); swap(sec, rk); rk[sa[1]] = num = 1;
        for(int i = 2; i <= n; i++)
            rk[sa[i]] = (sec[sa[i]] == sec[sa[i-1]] && sec[sa[i]+l] == sec[sa[i-1]+l]) ? num : ++num;
        m = num;
    }
}

void get_height(){
    int j, k = 0;
    for(int i = 1; i <= n; i++){
        if(k) k--;
        j = sa[rk[i]-1];
        while(a[i+k] == a[j+k]) k++;
        height[rk[i]] = k;
    }
}

int main(){
    ios::sync_with_stdio(false);
    cin >> n >> k;
    for(int i = 1; i <= n; i++) cin >> a[i];
    SuffixArray(), get_height();
    h = 1, t = 0;
    for(int i = 1; i <= n; i++){ // i for ranks
        while(h <= t && height[i] <= height[q[t]]) t--;
        q[++t] = i;
        while(h <= t && q[t]-q[h]+1 > k-1) h++;
        ans = max(ans, height[q[h]]);
    }
    cout << ans << endl;
    return 0;
}
原文地址:https://www.cnblogs.com/BCOI/p/10314585.html