ZOJ 3829 Known Notation【贪心】【好题】

Known Notation

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2

可以参照:链接


数字的个数要要保证比*的个数多1,不够的话优先补在开头是最优的。
然后遍历一遍字符串,碰到数字+1,碰到
*-1,保证数字的个数大于等1,
如果不够减的话,可以和最后面的一个数字交换位置
——交换比插入更优,因为添加和交换代价都是1。
考虑(****111*)交换成(1***11**)后插入3个1为(1111***11**)为4步
                插入则需要插5个1故交换优于插入


用这种方法要对前面符号满足后面有多余数字的进行特判(111*1)和对纯数字(111)进行特判,不过本体数据较弱,可不进行特判。

#include<iostream>	
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<map>
#include<set>
#include<stack>
#include<bitset>
#include<numeric>
#include<vector>
#include<string>
#include<iterator>
#include<cstring>
#include<functional>
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;

const int maxn = 1010;
const int mod = 1e9 + 7;
const double pi = 3.14159265358979;

typedef pair<int, int> P;
typedef long long ll;
typedef unsigned long long ull;

int len, num, c, a, ans;
char s[maxn] = { 0 };

void init()
{
	len = strlen(s);
	num = 0;
	c = 0;
	a = 0;
	ans = 0;
	for (int i = 0; i < len; i++)
	{
		if (s[i] == '*')
		{
			c++;
		}
		else
		{
			a++;
		}
	}
	if (a <= c)
	{
		num += c + 1 - a;
		ans = c + 1 - a;
	}
}

int last()
{
	for (int i = len - 1; i >= 0; i--)
	{
		if (s[i] != '*')
			return i;
	}
	return 0;
}


int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf(" %s", s);
		init();
		bool flag = 0;
		for (int i = 0; i < len; i++)
		{
			if (s[i] != '*')
			{
				num++;
			}
			else
			{
				if (i == len - 1)
				{
					if (num > 2)
					{
						flag = 1;
						num = 1;
						break;
					}
				}
				if (num > 1)
				{
					num--;
				}
				else
				{
					ans++;
					num++;
					swap(s[i], s[last()]);
				}
			}
		}
		if (flag&&num >= 2) ans++;
		cout << ans << endl;
	}
}


Fighting~
原文地址:https://www.cnblogs.com/Archger/p/12774767.html