算法训练 区间k大数查询

/*
问题描述

算法训练 区间k大数查询  

给定一个序列,每次询问序列中第l个数到第r个数中第K大的数是哪个。
输入格式

第一行包含一个数n,表示序列长度。

第二行包含n个正整数,表示给定的序列。

第三个包含一个正整数m,表示询问个数。

接下来m行,每行三个数l,r,K,表示询问序列从左往右第l个数到第r个数中,从大往小第K大的数是哪个。序列元素从1开始标号。
输出格式
总共输出m行,每行一个数,表示询问的答案。
样例输入
1 2 3 4 5
1 5 2
3 2
样例输出
2
数据规模与约定

对于30%的数据,n,m<=100;

对于100%的数据,n,m<=1000;

保证k<=(r-l+1),序列中的数<=106。
*/
import java.util.Arrays;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int[] a = new int[n];
        for (int i = 0; i < n; i++)
            a[i] = sc.nextInt();
        int m = sc.nextInt();
        int[] answer = new int[m];
        for (int i = 0; i < m; i++) {
            int l = sc.nextInt();
            int r = sc.nextInt();
            int k = sc.nextInt();
            int t[] = Arrays.copyOfRange(a, l - 1, r);
            Arrays.sort(t);
            answer[i] = t[t.length - (k - 1) - 1];
        }
        for (int i = 0; i < m; i++)
            System.out.println(answer[i]);
    }

}
原文地址:https://www.cnblogs.com/Alpharun/p/8622707.html