POJ 1936

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#define N 100005
using namespace std;
char str1[N];
char str2[N];
int main()
{
    int i,j;
    while(cin>>str1>>str2)
    {
        int len1=strlen(str1);
        int len2=strlen(str2);
        int t=0;
        int tt=0;
        for(i=0;i<len1;i++)
        {
            for(j=tt;j<len2;j++)
            {
                tt=j+1;
                if(str1[i]==str2[j])
                {
                    t++;
                    break;
                }
            }
        }
        //cout<<t<<endl;
        if(t==len1)
            printf("Yes ");
        else
            printf("No ");
    }
}

原文地址:https://www.cnblogs.com/Aa1039510121/p/5809209.html