【hdu 1536】S-Nim

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7410 Accepted Submission(s): 3127

Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player’s last move the xor-sum will be 0.

The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

Output
For each position: If the described position is a winning position print a ‘W’.If the described position is a losing position print an ‘L’. Print a newline after each test case.

Sample Input

2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0

Sample Output

LWW
WWL

【题目链接】:http://acm.hdu.edu.cn/showproblem.php?pid=1536

【题解】

/*
    s是个集合!
    每次只能拿走s集合里面的数字大小的个数;
    它没有说是有序的..
    所以从小到大枚举不能直接break;(先排序就可以了);
    算出每组S的对应的sg函数(0..10000);
    然后看看所有的h的异或值是不是0,是0就先手输;
    否则先手赢;
    子游戏的sg函数是能够叠加的(用抑或叠加)就变成组合博弈了(听起来很高端吧~); 
*/


【完整代码】

#include <bits/stdc++.h>
using namespace std;
#define rep1(i,a,b) for (int i = a;i <= b;i++)
#define rei(x) scanf("%d",&x)

const int MAXK = 1e2+10;
const int MAXH = 1e4+10;

int k,s[MAXK],sg[MAXH],m,l,h[MAXK];
bool flag[MAXK];

int main()
{
    //freopen("D:\rush.txt","r",stdin);
    rei(k);
    while (k!=0)
    {
        rep1(i,1,k)
            rei(s[i]);
        sort(s+1,s+1+k);
        sg[0] = 0;
        rep1(i,1,10000)
        {
            rep1(j,0,100)
                flag[j] = false;
            for (int j = 1;i-s[j]>=0 && j<=k;j++)
                flag[sg[i-s[j]]] = true;
            rep1(j,0,100)
                if (!flag[j])
                {
                    sg[i] = j;
                    break;
                }
        }
        rei(m);
        rep1(i,1,m)
        {
            int temp = 0;
            rei(l);
            rep1(j,1,l)
            {
                rei(h[j]);
                temp = temp^sg[h[j]];
            }
            if (temp == 0)
                printf("L");
            else
                printf("W");
        }
        puts("");
        rei(k);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/AWCXV/p/7626737.html