PAT 1104 Sum of Number Segments

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^5^. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

分析
这道题比较简单

#include<iostream>
#include<vector>
#include<iomanip>
using namespace std;
int main(){
  int N;
  cin>>N;
  double sum=0.00;
  vector<double> vi(N,0);
  for(int i=0; i<N; i++)
    cin>>vi[i];
  for(int i=1; i<=vi.size(); i++)
    sum+=vi[i-1]*(i)*(N-i+1);
  cout<<setiosflags(ios::fixed)<<setprecision(2)<<sum<<endl;
  return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501860.html