PAT 1085. Perfect Sequence

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

分析

这题跟的排列顺序无关,至于数列的最大值和最小值有关,故可以进行排序后再处理

#include<iostream>
#include<vector>
#include<algorithm> 
using namespace std;
int main(){
	long int n,p;
	cin>>n>>p;
	vector<long int> v(n);
	for(int i=0;i<n;i++)
	    cin>>v[i];
	sort(v.begin(),v.end());
	long int len=0;
	for(int i=0;i<n-len;i++){
		for(int j=i+len;j<n;j++)
		    if(v[j]<=v[i]*p) len++;
		    else break;
	}
	cout<<len<<endl;
	return 0;
} 
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8409702.html