PAT 1068. Find More Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^4, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

分析

一直对动态规划不熟悉,连最简单的01背包和完全背包问题都似懂非懂的我这题做不出来,参考了被人的代码,以下是分析:
分析:01背包问题,因为要输出从小到大的排列,可以先把硬币面额从大到小排列,然后用bool类型的choice[i][j]数组dp[i][j]是否选取,如果选取了就令choice为true;然后进行01背包问题求解,如果最后
求解的结果不是恰好等于所需要的价值的,就输出No Soultion,否则从choice[i][j]判断选取的情况,i从n到1表示从后往前看第i个物品的选取情况,j从m到0表示从容量m到0是否选取(j = j – w[i]),把选取情> 况压入arr数组中,最后输出arr数组。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int dp[10010],w[10010];
bool choice[10010][10010];
bool cmp(int p,int q){
	return p>q;
}
int main(){
	int n,m;
	cin>>n>>m;
	for(int i=1;i<=n;i++)
	    cin>>w[i];
	sort(w+1,w+n+1,cmp);
	for(int i=1;i<=n;i++)
	    for(int j=m;j>=w[i];j--)
	    	if(dp[j]<=dp[j-w[i]]+w[i]){
	    	   dp[j]=dp[j-w[i]]+w[i];
	    	   choice[i][j]=true;
			}
	if(dp[m]!=m) cout<<"No Solution"<<endl;
	else{
		vector<int> arr;
		int v=m, index=n;
		while(v>0){
			if(choice[index][v]==true){
				arr.push_back(w[index]);
				v-=w[index];
			}
			index--;
		}
		 for(int i = 0; i < arr.size(); i++) {
            if(i != 0) printf(" ");
            printf("%d", arr[i]);
        }
	}
	return 0;
} 
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8372523.html