PAT 1067. Sort with Swap(0,*)

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9

分析
这道题用到了表排序中N个数字的排列由若干独立的环组成的知识。
1.单元环swap(0,i)次数为0;
2.有0的非单元环,swap(0,i)次数为n-1;
3.无0的单元环,可以先把环里随便一个数和0交换一次,这样整个环就变成了含0的n+1个元素的非单元环,根据前面的情况2,次数为(n+1)-1,但还要加上把0换进去的那次,故swap(0,i)次数为n+1;
代码如下:

#include<iostream>
using namespace std;
int main(){
	int n,sum=0;
	cin>>n;
	int a[n],visited[n]={0};
	for(int i=0;i<n;i++)
	    cin>>a[i];
	for(int i=0;i<n;i++){
		int temp=i,cnt=0,flag=0;
		while(visited[temp]!=1){
			 cnt++;
			 if(a[temp]==0) flag=1;
			 visited[temp]=1;
			 temp=a[temp];
		}
		if(cnt>1&&flag==1) sum+=cnt-1;
		else if(cnt>1&&flag==0) sum+=cnt+1;
	}
	cout<<sum;
	return 0;
} 
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8371333.html