PAT 1040. Longest Symmetric String

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

分析
本题不难,在遍历时可以压缩一下

#include<iostream>
using namespace std;
string s;
bool issymmetric(int i,int j){
	while(i!=j){
		if(s[i]!=s[j]) return false;
		if(j-i==1) break; //如果是偶数对称的话
                i++; j--;
	}
	return true;
}
int main(){
	getline(cin,s);
	int max_len=1;
	for(int i=0;i<s.size()-max_len;i++){
		char c=s[i];
	    for(int j=s.size();j>i+max_len-1;j--){
	    	if(s[j]==c&&issymmetric(i,j)==true){
	    	   max_len=j-i+1>max_len?j-i+1:max_len;	
		}	
	   }
	} 
	cout<<max_len<<endl;
	return 0;
}

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8305057.html