PAT 1037. Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

分析
这道题可以先排序从小到大,然后用两个迭代器先从前面开始扫描,如果两个都是负数,则加到sum上,直到遇到不都是负数;然后从后面开始扫描,如果两个都是正数,加到sum上,知道遇到不都是正数;

#include<iostream>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
	long long int sum=0,n;
	cin>>n;
	vector<long long int> coupons(n);
	for(int i=0;i<n;i++)
	    cin>>coupons[i];
	cin>>n;
	vector<long long int> values(n);
	for(int i=0;i<n;i++)
	    cin>>values[i];
	sort(coupons.begin(),coupons.end());
	sort(values.begin(),values.end());
	auto it1=coupons.begin(),it2=values.begin();
	while(*it1<0&&*it2<0&&it1<coupons.end()&&it2<values.end()){
		sum+=(*it1)*(*it2);
		it1++; it2++;
	}
	it1=coupons.end()-1; it2=values.end()-1;
	while(*it1>0&&*it2>0&&it1>=coupons.begin()&&it2>=values.begin()){
		sum+=(*it1)*(*it2);
		it1--; it2--;
	}
	cout<<sum<<endl;
	return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8301536.html