1031. Hello World for U

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

分析

由题可得1:2*n1+n2=N+2;
       2:n1<=n2;
	   3:3<=n2<=N;
由1,3可得 n2>=(N+2)/3,再由1计算出n1
所以 n2 等于最小的大于等于(N+2)/3的整数,但是如果计算出n1,n2不是整数的话(即 N+2-n2 不是偶数的话),就把n2+1,在算出n1;
至于输出格式的控制,可以先输出n1-1行(先输出s[i],在输出n2-2个空格,再输出s[s.size()-1-i]),然后输出剩余的底部就行了。
#include<iostream>
#include<math.h>
using namespace std;
int main(){
	string s;
	cin>>s;
	int n1,n2,n3;
	n2=ceil((s.size()+2)/3.0);
	n2=(s.size()+2-n2)%2>0?n2+1:n2;
	n1=(s.size()+2-n2)/2;
	for(int i=0;i<n1-1;i++){
	    cout<<s[i];
	    for(int j=0;j<n2-2;j++)
	        cout<<" ";
	    cout<<s[s.size()-i-1]<<endl;
	}
	for(int i=n1-1;i<n1-1+n2;i++)
	    cout<<s[i];
	return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8289332.html