hdu 1004 Let the Balloon Rise

Time Limit:1000MS     Memory Limit:32768KB    64bit

IO Format:%I64d & %I64u

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result. 

This year, they decide to leave this lovely job to you. 
 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 
 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 
 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
 

Sample Output

red
pink
 
AC Code--Java
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		
		int [] it=new int[1024];
		String[][] a = new String[1024][1];
		
		while (n != 0) {
			for (int i = 0; i < n; i++) {
				a[i][0] = sc.next();
				for(int x=0;x<i;x++){
					if(a[i][0].compareTo(a[x][0])==0){
						it[i]++;
					}
				}
			}
		
			int max=0;
			for (int j = 0; j < n; j++) {
				if(it[j]>=max){
					max=j;
				}
			}
			System.out.println(""+a[max][0]);
			n=sc.nextInt();
		}
	}
}

  

 
原文地址:https://www.cnblogs.com/A--Q/p/5665189.html