hdu 1003 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 
Author
Ignatius.L
 
Recommend
We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 
 
如果都是负数,自然找到最大的负数即可,否则可以用动态规划法,如果sum<0了,那就没必要继续存了,只会影响了后面的,把后面的变小了,此时置sum为0.
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 0x3f3f3f3f
#define MAX 1000
using namespace std;

int n,m,d;
int main() {
    scanf("%d",&n);
    for(int i = 1;i <= n;i ++) {
        if(i > 1) putchar('
');
        scanf("%d",&m);
        int l = 1,sum = 0,maxsum = 0,a = 0,b = 0,maxnum = -inf,t;
        for(int j = 1;j <= m;j ++) {
            scanf("%d",&d);
            if(d > maxnum) {
                maxnum = d;
                t = j;
            }
            sum += d;
            if(sum < 0) {
                sum = 0;
                l = j + 1;
                continue;
            }
            if(sum > maxsum) {
                maxsum = sum;
                a = l;
                b = j;
            }
        }
        if(!a) {
            a = b = t;
            maxsum = maxnum;
        }
        printf("Case %d:
%d %d %d
",i,maxsum,a,b);
    }
}
原文地址:https://www.cnblogs.com/8023spz/p/9748903.html