poj 2385 Apple Catching

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

题意不难理解,两棵树,每一分钟要么从一号或者二号掉下苹果,可以穿梭于两棵树之间,当然不能同时接到两棵树的苹果,而且穿梭的次数有限,最初在一号树下,问能接到多少苹果,每一分钟都可以有不同的选择,实际上需要找到一条穿梭的最佳路线,所以我们需要记录,某一时间,穿梭几次的状态,第i分钟,穿梭了j次获得苹果数dp[i][j],只可能承接于两种状态,要么他上一分钟就已经穿梭了j次了,要么上一分钟穿梭了j - 1次,然后判断第i分钟穿梭到的位置是否接到苹果,这很好判断,如果j是奇数,则在二号树下,如果j是偶数,就是在一号树,如果j和树号的和都是奇数,所以对二取模即可。
代码:
#include <iostream>
#include <cstdio>
using namespace std;
int dp[1001][31];///第几分钟 第几步 的苹果数
int apple[1001];
int main() {
    int n,m,ans = 0;
    scanf("%d%d",&n,&m);
    for(int i = 0;i < n;i ++) {
        scanf("%d",&apple[i]);
    }
    dp[1][apple[0] - 1] = 1;///第一分钟
    for(int i = 2;i <= n;i ++) {
        dp[i][0] = dp[i - 1][0] + apple[i - 1] % 2;///第i分钟 0步的苹果数
        for(int j = 1;j <= m;j ++) {
            dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]);
            dp[i][j] += (apple[i - 1] + j) % 2;///是否接到苹果
        }
    }
    for(int i = 0;i <= m;i ++) {
        ans = max(ans,dp[n][i]);
    }
    printf("%d",ans);
}

 重做

代码:

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>

using namespace std;

int t,w,d;
int dp[1001][31];
int main() {
    scanf("%d%d",&t,&w);
    for(int i = 1;i <= t;i ++) {
        scanf("%d",&d);
        if(i == 1) dp[i][d - 1] = 1;
        else {
            dp[i][0] = dp[i - 1][0] + (d == 1);
            for(int j = 1;j <= w;j ++) {
                dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]);
                dp[i][j] += (d - 1 == j % 2);
            }
        }
    }
    int ans = 0;
    for(int i = 1;i <= w;i ++) {
        ans = max(ans,dp[t][i]);
    }
    printf("%d",ans);
}
原文地址:https://www.cnblogs.com/8023spz/p/9525868.html