poj 3669 Meteor Shower

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

Source

起点在坐标系的(0,0),给出一组数据x,y,t,表示在t时间点(x,y)会被袭击,同时他的上下左右的邻接点都会被破坏,被破坏的点无法经过,问能否平安到达安全地带(不会被破坏的点)。
bfs遍历,需要注意的是,别袭击的范围是x和y不超过300,但是可移动的点是整个第一象限。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <cstdlib>
#include <queue>
#define MAX 305
#define inf 0x3f3f3f3f
using namespace std;
typedef pair<int,int> p;
typedef pair<p,int> pa;
int t[MAX][MAX];
bool vis[MAX][MAX];
int dir[4][2] = {0,1,1,0,0,-1,-1,0};
bool ifin(int x,int y) {///判断点是否在地图内
    if(x < 0 || y < 0)return false;
    return true;
}
void mark(int x,int y,int time) {///更新被破坏时间
    t[x][y] = min(t[x][y],time);
    for(int i = 0;i < 4;i ++) {
        int tx = x + dir[i][0];
        int ty = y + dir[i][1];
        if(ifin(tx,ty)) {
            t[tx][ty] = min(t[tx][ty],time);
        }
    }
}
int bfs() {///遍历地图找答案
    queue<pa> q;
    if(t[0][0] == inf)return 0;
    if(t[0][0])q.push(pa(p(0,0),0));
    vis[0][0] = 1;
    while(!q.empty()) {
        int time = q.front().second;
        int x = q.front().first.first;
        int y = q.front().first.second;
        q.pop();
        for(int i = 0;i < 4;i ++) {
            int tx = x + dir[i][0];
            int ty = y + dir[i][1];
            if(!ifin(tx,ty) || vis[tx][ty] || time + 1 >= t[tx][ty])continue;
            if(t[tx][ty] == inf)return time + 1;
            q.push(pa(p(tx,ty),time + 1));
            vis[tx][ty] = true;
        }
    }
    return -1;
}
int main() {
    int m,x,y,time;
    while(~scanf("%d",&m)) {
        memset(t,inf,sizeof(t));///初始化时间
        memset(vis,false,sizeof(vis));
        for(int i = 0;i < m;i ++) {
            scanf("%d%d%d",&x,&y,&time);
            mark(x,y,time);
        }
        printf("%d",bfs());
    }
}
原文地址:https://www.cnblogs.com/8023spz/p/9469100.html