hdu 1556 Color the ball

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。Output每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1


区间更新,开一个数组,每个元素的值表示从这个点到n的集体状态变化,那么给出区间[a,b],s[a] ++,s[b + 1] --,求某个点只需要求前缀和。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int n,a,b,s[100002],ans;
int main()
{
    while(scanf("%d",&n) != EOF && n)
    {
        memset(s,0,sizeof(s));
        ans = 0;
        for(int i = 0;i < n;i ++)
        {
            scanf("%d%d",&a,&b);
            s[a] ++;
            s[b + 1] --;
        }
        for(int i = 1;i <= n;i ++)
        {
            ans += s[i];
            if(i > 1)putchar(' ');
            printf("%d",ans);
        }
        putchar('
');
    }
}
原文地址:https://www.cnblogs.com/8023spz/p/9002615.html