1144. The Missing Number (20)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

 代码:

#include <iostream>
#include <map>
using namespace std;

int main()
{
    int n,d;
    map<int,int> q;
    cin>>n;
    for(int i = 0;i < n;i ++)
    {
        cin>>d;
        q[d] = 1;
    }
    d = 0;
    while(q[++ d]);
    cout<<d;
}
原文地址:https://www.cnblogs.com/8023spz/p/8877139.html