1125. Chain the Ropes (25)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14

哈夫曼思想,每次选最短的两根,可以使耗损最少,变成新的一根绳子继续放到序列里排序,直到最后形成一根绳子。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,s[10000],d;
int main()
{
    cin>>n;
    for(int i = 0;i < n;i ++)
    {
        cin>>s[i];
    }
    sort(s,s + n);
    for(int i = 0;i < n - 1;i ++)
    {
        d = (s[i] + s[i + 1]) / 2;
        for(int j = i + 2;j < n;j ++)
        {
            if(s[j] < d)s[j - 1] = s[j];
            else
            {
                s[j - 1] = d;
                break;
            }
        }
    }
    cout<<d;
}
原文地址:https://www.cnblogs.com/8023spz/p/8493795.html