Backward Digit Sums

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   4

4 3 6
7 9
16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16
Sample Output
3 1 2 4
Hint
Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
 
找出n个数1-n的一个序列按题目要求合并到最后要等于给出的值,dfs一下,至于每个数加了多少次,用了杨辉三角的知识,记得高中做过杨辉三角的题,第n行第i个元素为c(n)(i),这里了是三角形倒过来了,仍然适用。
 
代码:
 
#include <iostream>
#include <string>

using namespace std;
int n,d,vis[11],num[11],flag = 0;
int csum();
void print();
void dfs(int k)
{
    if(flag)return;
    if(k > n)
    {
//        cout<<csum()<<endl;
        if(csum() == d)
        {
            print();
            flag = 1;
            return;
        }
    }
    for(int i = 1;i <= n;i ++)
    {
        if(vis[i] == 0)
        {
            vis[i] = 1;
            num[k] = i;
            dfs(k + 1);
            vis[i] = 0;
        }
    }
}
void print()
{
    cout<<num[1];
    for(int i = 2;i <= n;i ++)
        cout<<' '<<num[i];
}
int counti(int k)
{
    int c = 1;
    for(int i = 0;i < k;i ++)
        c *= (n - 1 - i);
    for(int i = 0;i < k;i ++)
        c /= (i + 1);
    return c;
}
int csum()
{
    int sum = 0;
    for(int i = 1;i <= n;i ++)
    {
        sum += num[i] * counti(i - 1);
    }
    return sum;
}
int main()
{
    cin>>n>>d;
    dfs(1);
}
原文地址:https://www.cnblogs.com/8023spz/p/7786961.html