B

---恢复内容开始---

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general. 

InputThe input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions. 
OutputFor each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice. 
Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

题目难点和遇到问题的分析:
    1.如何快速的让所给序列反序的排列好;
    2.我们分析可以知道,排好序后,前面加过的数可以不用再在反复相加,相当于减少了一遍从小到达的重复;(难点在于我们怎么停在下一位数上,而不是返回第一个数)
    3.如何避免重复的情况出现(如3,3,2会有3+2,3+2两个);
解决方法和思想:
    1.sort(a,a+n,cmp)重构sort的排序方法;
    int cmp(int x,int y)
    {
        return x>y;
    }
     2.DFS(开始位置,总数和,储存数组位置);利用循环DFS(j+1,**,**)。循环一次后就会停在下一位,而不是回到0;
    
    for(int j=x;j<n;j++)
    {
        num[sum] = array[j];
        //cout << "X+1: "<< j << "----" << num[sum] << endl;
        DFS(j+1,total+array[j],sum+1);
        while(array[j]==array[j+1] && j+1<n)
            j++;
    }
   3. DFS()后,返回到上一次的时候,判断它的下一位数是不是和自身相同,如果是j++,不可以用continue;

while(array[j]==array[j+1] && j+1<n)
            j++;    
    总代码 :
  
#include <iostream>
#include <algorithm>
#include <cstring>
#define maxn 15
using namespace std;
int t,n,array[maxn];
int num[maxn],mark;

int cmp(int x,int y)
{
    return x>y;
}

void DFS(int x,int total,int sum)
{
    if(total > t)
        return;
    if(total == t)
    {
        mark = 1;
        for(int i=0;i<sum;i++)
        {
            if(i)
                cout << "+" << num[i];
            else
                cout << num[i];
        }
        cout << endl;
    }

    for(int j=x;j<n;j++)
    {
        num[sum] = array[j];
        //cout << "X+1: "<< j << "----" << num[sum] << endl;
        DFS(j+1,total+array[j],sum+1);
        while(array[j]==array[j+1] && j+1<n)
            j++;
    }
}

int main()
{
    while(cin >> t >> n && n)
    {
        memset(array,0,sizeof(array));
        for(int i=0;i<n;i++)
            cin >> array[i];
        sort(array,array+n,cmp);
        mark = 0;
        cout <<"Sums of " << t << ":" <<"
";
        DFS(0,0,0);
        if(!mark)
            cout <<"NONE" << "
";
    }
    return 0;
}
 
原文地址:https://www.cnblogs.com/7750-13/p/7260376.html