Matrix 二维树状数组的第二类应用

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17976   Accepted: 6737

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int ms=1e3+10;
int map[ms][ms];
int n,m;
int lowbit(int t)
{
    return t&(-t);
}
void updata(int x,int y,int d)
{
    while(x>0)
    {
        int y1=y;
        while(y1>0)
        {
            map[x][y1]+=d;
            y1-=lowbit(y1);
        }
        x-=lowbit(x);
    }
}
int getsum(int x,int y)
{
    int sum=0;
    while(x<=n)
    {
        int y1=y;
        while(y1<=n)
        {
            sum+=map[x][y1];
            y1+=lowbit(y1);
        }
        x+=lowbit(x);
    }
    return sum;
}
int main()
{
    int i,j,k,t,tcase;
    //#ifndef oo
    //cout<<"dkkjdkk"<<endl;
    //#endif
    cin>>tcase;
    while(tcase--)
    {
        cin>>n>>m;
        memset(map,0,sizeof(map));
        char s[5];//避免回车符的影响  否则  getchar() 
         while(m--)
         {
             cin>>s;
             if(s[0]=='C')
             {
                 int x1,y1,x2,y2;
                 cin>>x1>>y1>>x2>>y2;
                 updata(x2,y2,1);
                updata(x1-1,y2,-1);
                updata(x1-1,y1-1,1);
                updata(x2,y1-1,-1);    
                //updata(x1-1,y1-1,1);    
             }
             else if(s[0]=='Q')
             {
                 int x,y;
                 cin>>x>>y;
                 cout<<getsum(x,y)%2<<endl;
             }
         }
         if(tcase)
             cout<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/767355675hutaishi/p/3862625.html