K

Description

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output

Output one line for each test, indicates the minimum HP loss.
 

Sample Input

1 10 2 2 100 1 1 100
 

Sample Output

20 201
 
 
解题思路:首先用sort函数对DPS/HPS进行排序,将最大的放在第一个;然后用一个循环算出没有人死亡时每一回合的总伤害;最后再用一个循环计算出对我的最小伤害,然后减去死亡英雄的伤害(我先杀第一个人,即攻击力最强大血量在同攻击力的人中最少的,只有当他死了总的攻击力才会改变)
 
 
代码如下:
 
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
struct bbb
{
      int t,v;
  }a[101];
int cmp(const void *a,const void *b)
{
bbb *c,*d;
c=(bbb *)a;
d=(bbb *)b;
return (c->t*d->v)-(d->t*c->v);
  }
  int main()
{
int i,n,base,ans;
while(scanf("%d",&n)!=-1)
{
base=0;
for(i=0;i<n;i++)
          { scanf("%d%d",&a[i].v,&a[i].t);
           base+=a[i].v;
          }
qsort(a,n,sizeof(a[0]),cmp);
ans=0;
for(i=0;i<n;i++)
{ ans+=base*a[i].t; base-=a[i].v;
}
printf("%d ",ans);
}
return 0;
}
原文地址:https://www.cnblogs.com/441179572qqcom/p/5693260.html