G

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input

* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output

* Line 1: A single integer that is the median milk output.
 

Sample Input

5 2 4 1 3 5
 

Sample Output

3

简单到爆炸

代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
     int n,a[10001];
     while(scanf("%d",&n)==1)
     {if(n%2!=0)
     {for(int i=0;i<n;i++)
     scanf("%d",&a[i]);
     sort(a,a+n);
     printf("%d ",a[n/2]);}}
     return 0;
}

 
 
原文地址:https://www.cnblogs.com/441179572qqcom/p/5693241.html