hdu 1690 Bus System

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3746    Accepted Submission(s): 943


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 
Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 
Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 
Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 
Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 
Source
 
Recommend
wangye
//floyd

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define N 2003
#define lson l,m,k<<1
#define rson m,r,k<<1|1
using namespace std;
__int64 map[103][103];
int index[103];
int main()
{
    int T,t=1;
    int l1,l2,l3,l4,c1,c2,c3,c4;
    int m,n;
    scanf("%d",&T);
    int i,j,k;
    int temp;
    while(T--)
    {
scanf("%d%d%d%d%d%d%d%d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
      map[i][i]=0,scanf("%d",&index[i]);
    for(i=1;i<n;i++)
       for(j=i+1;j<=n;j++)
        {
           temp=index[i]-index[j];
          if(temp<0)
           temp=-temp;

          if(temp<=l1)
           {
              map[i][j]=map[j][i]=c1;
           }
          else if(l1<temp&&temp<=l2)
          {
              map[i][j]=map[j][i]=c2;
          }
          else if(l2<temp&&temp<=l3)
          {
              map[i][j]=map[j][i]=c3;
          }
          else if(l3<temp&&temp<=l4)
          {
              map[i][j]=map[j][i]=c4;
          }
          else {map[i][j]=map[j][i]=-1;}
        }
    for(k=1;k<=n;k++)
      for(i=1;i<=n;i++)
       for(j=1;j<=n;j++)
        if(map[i][k]!=-1&&map[k][j]!=-1)
           if(map[i][j]>map[i][k]+map[k][j]||map[i][j]==-1)
            map[i][j]=map[i][k]+map[k][j];
    printf("Case %d:\n",t++);
    while(m--)
    {
    scanf("%d%d",&i,&j);
    if(map[i][j]!=-1)
    {
printf("The minimum cost between station %d and station %d is %I64d.\n",i,j,map[i][j]);
    }
    else
    {
printf("Station %d and station %d are not attainable.\n",i,j);
    }
    }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2609685.html