HDU 1754 I Hate It

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15716    Accepted Submission(s): 6099


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 
Output
对于每一次询问操作,在一行里面输出最高成绩。
 
Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 
Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 
Author
linle
 
Source
 
Recommend
lcy

//线段树基础题目2.

#include <iostream>
#include <stdio.h>
#include <string.h>
#define lson l,m,k<<1
#define rson m+1,r,k<<1|1
#define N 200000
using namespace std;
int st[N<<2];
void up(int &k)
{
    st[k]=st[k<<1]>st[k<<1|1]?st[k<<1]:st[k<<1|1];

}
void build(int l,int r,int k)
{
    if(l==r)
    {
        scanf("%d",&st[k]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    up(k);
}
void updata(int &index,int &va,int l,int r,int k)
{
    if(l==r)
    {
        st[k]=va;
        return ;
    }
    int m=(l+r)>>1;
    if(index>m) updata(index,va,rson);
    else updata(index,va,lson);

    up(k);
}
int query(int &L,int &R,int l,int r,int k)
{
    if(L<=l&&R>=r)
    {
        return st[k];
    }
    int t1=0,t2=0,m=(l+r)>>1;
    if(L<=m) t1=query(L,R,lson);
    if(R>m) t2=query(L,R,rson);
    return t1>t2?t1:t2;
}
int main()
{
    int n,m;
    char C;
    int a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        build(1,n,1);
        while(m--)
        {
            getchar();
            scanf("%c",&C);
            if(C=='U')
            {
                scanf("%d%d",&a,&b);
                updata(a,b,1,n,1);
            }
            else
            {
                scanf("%d%d",&a,&b);
                printf("%d\n",query(a,b,1,n,1));
            }
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2595273.html