HDU 1083 Courses

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1888    Accepted Submission(s): 848


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
 
Sample Output
YES
NO
 
Source

//利用最大流写的二分匹配算法,初试、时间上挺慢、不过很开心呀、、自己的第一个二分匹配算法、

//呵呵,对于二分图图、要自己给定一个起点和一个终点,然后求最大流、呵呵

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#define V 403
#define inf 13
using namespace std;
int f[V][V],c[V][V];
int main()
{
    int P,N,T,M;
    int fa[V],r[V];
    int sum;
    int i,j,u,v,co;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&P,&N);
        memset(f,0,sizeof(f));
        memset(c,0,sizeof(c));
        for(i=1;i<=P;i++)
        {
            c[0][i]=1;
          scanf("%d",&co);
          for(j=0;j<co;j++)
          {
             scanf("%d",&u);
              c[i][P+u]=1;
          }
        }
        M=P+N+1;
        for(i=1;i<=N;i++)
        {
            c[i+P][M]=1;
        }
         sum=0;
        for(;;)
        {
            memset(r,0,sizeof(r));
            queue<int> Q;
            r[0]=inf;
            Q.push(0);
            while(!Q.empty())
            {
                u=Q.front();Q.pop();
                for(v=1;v<=M;v++)
                if(!r[v]&&c[u][v]>f[u][v])
                {
                    r[v]=r[u]<=c[u][v]-f[u][v]?r[u]:c[u][v]-f[u][v];
                    fa[v]=u;
                    Q.push(v);
                }
            }
            if(r[M]==0)
             break;
           for(u=M;u!=0;u=fa[u])
           {
               f[fa[u]][u]+=r[M];
               f[u][fa[u]]-=r[M];
           }
           sum+=r[M];
        }
       if(sum==P)
         printf("YES\n");
        else
         printf("NO\n");
    }
    return 0;
}

//对早上的这题时间很不满意呀、4000+MS,去学了下匈牙利算法,156Ms、差别还真大、而且用的内存和代码长度都更

//少


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
#define L 103
#define R 303
using namespace std;
bool map[L][R],v[R];
int match[R];
int P,N,T;
bool DFS(const int &k)//真是短小精悍的东西呀
{
    for(int i=1;i<=N;i++)
      if(map[k][i]&&!v[i])
      {
          v[i]=1;
          if(match[i]==0||DFS(match[i]))
             {
                 match[i]=k;
                 return 1;
             }
      }
    return 0;
}
int main()
{
   int i,j,k,t;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%d%d",&P,&N);
       memset(map,0,sizeof(map));
       for(i=1;i<=P;i++)
         {
             scanf("%d",&t);
             for(j=0;j<t;j++)
               scanf("%d",&k),map[i][k]=1;
         }
         k=0;
         memset(match,0,sizeof(match));
       for(i=1;i<=P;i++)
        {
            memset(v,0,sizeof(v));
            if(DFS(i)) k++;
        }
       if(k==P)
         printf("YES\n");
        else
        printf("NO\n");
   }

    return 0;
}


原文地址:https://www.cnblogs.com/372465774y/p/2585932.html