HDU 1013 Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29353    Accepted Submission(s): 8974


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 
Output
For each integer in the input, output its digital root on a separate line of the output.
 
Sample Input
24 39 0
 
Sample Output
6 3
 
Source
 
//常规做法
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int del(int a)
{
    int b=0;
    while(a>0)
    {
       b+=a%10;
       a/=10;
    }
    return b;
}
int main()
{
    char s[1003];
    int i;
    int a;
    while(scanf("%s",s),s[0]!='0')
    {   a=0;
       for(i=0;s[i]!='\0';i++)
          a+=s[i]-'0';
        while(a>9)
        {
            a=del(a);
        }
        printf("%d\n",a);
    }
    return 0;
}

//快捷算法
//算法思想:
//一个数 模9等于各位数字和模9,例如 33%9=6%9;
//证明: a1a2a3...an%9=((a1*10^n-1)%9+(a2*10^n-2)%9...)%9
//右边 a1*(9999..9+1)%9=a1%9,以此类推、、、、、
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
    char s[1003];
    int i;
    int a;
    while(scanf("%s",s),s[0]!='0')
    {   a=0;
       for(i=0;s[i]!='\0';i++)
          a=a*10+s[i]-'0',a=a%9;
        if(a==0) a=9;
        printf("%d\n",a);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2585669.html