POJ 1862 Stripies(哈夫曼)

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9301   Accepted: 4527

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion
 
//开始的时候当成赫夫曼来算了,用小堆,发现结果对不上,在纸上写了下发现是大堆
//就是让大的数尽量放在开更式里面,这样会使最后结果尽可能少,其实也算是赫夫曼算法了、呵呵
#include <iostream>
#include <stdio.h>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
    int n;
    double t,a,b;
    while(scanf("%d",&n)!=EOF)
    {
       // priority_queue<double,vector<double>,greater<double> > Q;
       priority_queue<double> Q;
        while(n--)
        {
            scanf("%lf",&t);
            Q.push(t);
        }
       while(Q.size()>1)
       {
           a=Q.top();Q.pop();
           b=Q.top();Q.pop();
           t=2*sqrt(a*b);
           Q.push(t);
       }
       printf("%.3lf\n",Q.top());

    }
    return 0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2582182.html