hdu 1272 小希的迷宫

Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
 
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
 
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0
8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0
3 8 6 8 6 4 5 3 5 6 5 2 0 0
-1 -1
 
Sample Output
Yes Yes No
 
Author
Gardon
 
Source
 
Recommend
lxj

//虽然这题A了,但是感觉这题目还是有些问题,按题意来说应该是无向的、可是我用树根来做的话明显是有向的,即 7 5 和5 7是不一样的

//如果我把第二组数据改成 1 8  8 7 8 9 5 7 4 7 6 7 3 7 2 6 0 0 这个图是一样的,但是我的代码运行是No,明显错了,这题明显不是并查集解的。

//正确的方法应该是 拓扑排序加上dfs算连通分支

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define N 100003
int v[N];
int
f[N];
bool
hash[N];
int
main()
{

  int
n,m,nt,i,t;
  bool
flag;
  while
(scanf("%d%d",&n,&m))
  {

      if
(n==-1&&m==-1)
          break
;
      memset(v,0,sizeof(v));t=1;
      memset(f,0,sizeof(f));nt=0;
      memset(hash,0,sizeof(hash));
      if
(!hash[n]) {hash[n]=1;nt++;}
      if
(!hash[m]) {hash[m]=1;nt++;}
      f[m]=n;flag=1;
      if
(m!=n)
      {
v[m]=n;t++;}
      if
(n||m)
      while
(scanf("%d%d",&n,&m),n||m)
      {

          if
(!flag)
              continue
;
          if
(f[m]&&n!=f[m])//判断一个节点是否有多个父节点,我把这句丢了还是AC,明显这题的数据很水,出题的本意应该是并查集
          {
flag=0; continue;}
         if
(!hash[n]) {hash[n]=1;nt++;}
         if
(!hash[m]) {hash[m]=1;nt++;}
          f[m]=n;
          while
(v[n]>0)
              n=v[n];
          while
(v[m]>0)
              m=v[m];
          if
(m==n)
          {
flag=0; continue;}
          v[m]=n;t++;
      }

     if
(nt!=t)
         flag=0;
     if
(flag)
         printf("Yes\n");
     else

        printf("No\n");
  }

   return
0;
}

原文地址:https://www.cnblogs.com/372465774y/p/2446855.html