HDU 1003 Max Sum

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 


 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 


 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 


 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 


 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6

 //话说这题当时我是看着代码,带入数据才明白的,好几个动态规划都是这样才明白的

#include <iostream>//简单的动态规划
#include <algorithm>
#include <cstdio>
#include <string.h>
#include <queue>
#include <stdlib.h>
using namespace
 std;
int
 main()
{
   //freopen("in.txt","r",stdin);
    int t,n,a,max,b,i,f,l,temp,flag=0;
    scanf("%d",&t);
    while
(t--)
    {

        scanf("%d%d",&n,&b);
        max=b;temp=f=l=1;
        if
(flag)
         printf("\n");
        flag++;
        for
(i=2;i<=n;i++)
        {

            scanf("%d",&a);
            if
(b<0)     //关键的代码
              {
b=a;temp=i;}
            else

              b+=a;
            if
(b>max)//关键的代码
             {

                max=b;
                f=temp;
                l=i;
             }
        }

      printf("Case %d:\n%d %d %d\n",flag,max,f,l);
    }

    return
 0;
}

                                                                  ------江财小子

原文地址:https://www.cnblogs.com/372465774y/p/2421661.html