04-树6 Complete Binary Search Tree (30分)

04-树6 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

提交代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

typedef int ElemType;

int GetLeftLength(int N){
    if (N == 1) {
        return 0;
    }
    int H = floor(log10(N + 1) / log10(2));
    int maxX = pow(2, H - 1);
    int X = N - maxX * 2 + 1;
    X = X < maxX ? X : maxX;
    int L = maxX + X - 1;
    return L;
}

void Solve(int ALeft, int ARight, int TRoot, int* A, int* T){
    int n = ARight - ALeft + 1;
    if(n==0){
        return;
    }
    int L = GetLeftLength(n);
    T[TRoot] = A[ALeft + L];
    int LeftTRoot = TRoot * 2 + 1;
    int RightTRoot = LeftTRoot + 1;
    Solve(ALeft, ALeft + L-1, LeftTRoot, A, T);
    Solve(ALeft + L + 1, ARight, RightTRoot, A, T);
}

int compare(const void*a, const void*b){
    return *(int*)a-*(int*)b;
}

int main(){
    int N;
    scanf("%d", &N);
    int *A = (int*)malloc(sizeof(ElemType)*N);
    int *T = (int*)malloc(sizeof(ElemType)*N);
    for(int i = 0; i < N; ++i){
        scanf("%d", A+i);
    }
    qsort(A, N, sizeof(int), compare);
    Solve(0,N-1,0,A,T);
    if(N <= 0)
        return 0;
    printf("%d", T[0]);
    for(int i = 1; i < N; ++i){
        printf(" %d", T[i]);
    }
    return 0;
}

提测结果:

 
 
原文地址:https://www.cnblogs.com/2018shawn/p/13375324.html