hdu 1379 DNA Sorting

DNA Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1924    Accepted Submission(s): 949


Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

 

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
 

 

Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.
 

 

Sample Input
1
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
 

 

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

struct DNA
{
    string s;
    int d;
};

int cmp(DNA a,DNA b){
    if(a.d!=b.d)return a.d<b.d;
    else return 0;
}

int main(){
    
    int t;
    int n,m;
    DNA dna[80];
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j;
        for(i = 0; i < m; ++i){
            cin>>dna[i].s;
            dna[i].d = 0; 
            for(j = 1; j < n; ++j)
            {
                for(int k = 0; k < j ;++k)
                {
                    if(dna[i].s[j] < dna[i].s[k])
                        dna[i].d++;
                }
            }
        }
        sort(dna,dna+m,cmp);
        for(i = 0; i < m; ++i)
            cout<<dna[i].s<<endl;
    }
    return 0;
}
View Code

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

struct DNA
{
    string s;
    int d;
};

int cmp(DNA a,DNA b){
    if(a.d!=b.d)return a.d<b.d;
    else return 0;
}

int main(){
   
    int t;
    int n,m;
    DNA dna[80];
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        int i,j;
        for(i = 0; i < m; ++i){
            cin>>dna[i].s;
            dna[i].d = 0;
            for(j = 1; j < n; ++j)
            {
                for(int k = 0; k < j ;++k)
                {
                    if(dna[i].s[j] < dna[i].s[k])
                        dna[i].d++;
                }
            }
        }
        sort(dna,dna+m,cmp);
        for(i = 0; i < m; ++i)
            cout<<dna[i].s<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/2014acm/p/3885498.html