字符串统计

字符串统计

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 18

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9

Author

lcy

Source

C语言程序设计练习(三)
#include<iostream>
#include<string>
using namespace std;
int main()
{
    int n;
    string a;
    
    while(scanf("%d",&n)!=EOF)
    {
        for(int k=0;k<n;k++)
        {
        cin>>a;
        int m=0;
        for(int i=0;i<a.length();i++)
        {
            if(a[i]>='0'&&a[i]<='9')
                m++;
        
        
        }
        cout<<m<<endl;
        }
    
    
    }





return 0;
}
原文地址:https://www.cnblogs.com/2013lzm/p/3255372.html