bzoj1677:求和

1677: [Usaco2005 Jan]Sumsets 求和

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 696  Solved: 387
[Submit][Status][Discuss]

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 1) 1+1+1+1+1+1+1 2) 1+1+1+1+1+2 3) 1+1+1+2+2 4) 1+1+1+4 5) 1+2+2+2 6) 1+2+4 Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

给出一个N(1≤N≤10^6),使用一些2的若干次幂的数相加来求之.问有多少种方法

Input

   一个整数N.

Output

方法数.这个数可能很大,请输出其在十进制下的最后9位.

Sample Input

7

Sample Output

6

有以下六种方式
1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

HINT

 

Source

Silver

草草草我弱智了,居然去用dfs。。。于是tle分明是简单的dp。。。。

-----------------------------------------------------------------------------------

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int a[100];
int f[1000005];
int main(){
 int n;
 scanf("%d",&n);
 for(int i=1;i<=n;i*=2)
   a[++a[0]]=i;
 int len=a[0];
 f[0]=1;
 for(int i=1;i<=len;i++){
  for(int j=a[i];j<=n;j++){
   f[j]+=f[j-a[i]];
   f[j]%=1000000000;
  }
 }
 printf("%d ",f[n]);
 return 0;
}

---------------------------------------------------------------------------------------

原文地址:https://www.cnblogs.com/20003238wzc--/p/4827313.html