HDU 1003 Max Sum

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6

#include <cstdio>
#include <iostream>
using namespace std;

int Kesha[100005];

int main() {
int t, k = 0;
scanf("%d", &t);

while(t--) {
k++;
int n, p = 0;
scanf("%d", &n);
for(int i=0; i<n; i++) {
scanf("%d", &Kesha[i]);
}
int sum = Kesha[0], max = Kesha[0];
int begin = 0, end = 0;
for(int i=1; i<n; i++) {
if(sum + Kesha[i] < Kesha[i]) { //如果当前值比Kesha[i]小的话则改为Kesha[i];
sum = Kesha[i];
p = i; //记录下改的位置;
}else {
sum = sum + Kesha[i];
}
if(sum > max) { //当前值比最大值大,则头尾都要改;
max = sum;
begin = p;
end = i;
}
}
printf("Case %d: %d %d %d ", k, max, begin+1, end+1);
if(t) printf(" "); //测试数据之后有空行;
}
return 0;
}

此题是一个近点的动态规划基础题,很多是以这个为模板的。

 
原文地址:https://www.cnblogs.com/1314wamm/p/5003400.html