poj 2155- Matrix (树状数组,二维,更新区间,查询单点)

 Matrix
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

和上一道类似,也是更新区间,查询单点。
用到了容斥原理。
/*************************************************************************
    > File Name: code/poj/2155.cpp
    > Author: 111qqz
    > Email: rkz2013@126.com 
    > Created Time: 2015年08月07日 星期五 00时42分38秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef unsigned long long ULL;
const int inf = 0x7fffffff;
const int N=1E3+7;
int c[N][N];
int n,m,x1,x2,y1,y2,x,y,t;

int lowbit ( int x)
{
    return x&(-x);
}
void update ( int x,int y ,int delta)
{
    for ( int i = x ; i  <= n ; i = i + lowbit(i))
    {
    for ( int j = y; j <= n ; j = j + lowbit(j))
    {
        c[i][j] = c[i][j] + delta;
    }
    }
}
int sum ( int x,int y)
{
    int res  = 0;
    for ( int i = x; i >= 1 ; i = i - lowbit (i))
    {
    for ( int j = y ; j >= 1 ; j = j - lowbit (j))
    {

        res  = res + c[i][j];
    }
    }
    return res;
}
int main()
{
    int T;
    cin>>T;
    while (T--)
    {
    memset(c,0,sizeof(c));
    scanf("%d %d",&n,&t);
    for ( int i = 1; i <=  t;  i ++ )
    {
        char cmd;
        cin>>cmd;
        if (cmd=='C')
        {
        scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
        update (x1,y1,1);
        update (x2+1,y1,1);
        update (x1,y2+1,1);
        update (x2+1,y2+1,1);
        }
        else
        {
        scanf("%d %d",&x,&y);
        int tmp;
        if (sum(x,y)%2==0)
            cout<<0<<endl;
        else cout<<1<<endl;
        }
    }
    cout<<endl;
    }
  
    return 0;
}
原文地址:https://www.cnblogs.com/111qqz/p/4709659.html