poj 3126 Prime Path (bfs)

Prime Path
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13813   Accepted: 7796

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
题意是说,给定两个四位素数a b 问从a变换到b,最少需要变换几次.
变换的要求是,每次只能改变一个数字,而且中间过程得到的四位数也必须为素数.
因为提到最少变换几次,容易想到bfs,bfs第一次搜到的一定是最短步数.

先打个素数表
然后写个函数判断两个四位数有几位数字不同,如果只有一位,返回true,否则返回false
然后竟然wa了两次!
下表写错!
pri[k++]=i;是先给pri[k]赋值,再k++;
pri[++k]=i;才是先增加,再赋值.这个搞错了.所以wa了....sad
/*************************************************************************
    > File Name: code/2015summer/searching/F.cpp
    > Author: 111qqz
    > Email: rkz2013@126.com 
    > Created Time: Fri 24 Jul 2015 01:16:23 AM CST
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef unsigned long long ULL;
const int N =1E4+5;
int pri[N],which[N];
int a,b,k;
bool flag;
int d[N];
bool prime(int x)
{
    for ( int i = 2 ; i*i<=x ;i++ )
    {
      if (x %i==0) return false;
    }
    return true;
}

bool ok (int x,int y)
{
    if (d[y]!=-1) return false;
    int res = 0; //记录两个数不对应不相等的数字的个数
    int xx=x,yy=y;
    while (x&&y)
    {
      if (x%10!=y%10) res++;
      x = x/10;
      y = y/10;
    }
 //   if (res==1) cout<<"x:"<<xx<<" y:"<<yy<<endl;
    if (res==1) return true;
    return false;
}
void bfs()
{
    queue<int>x;
    memset(d,-1,sizeof(d));
    x.push(a);
    d[a]=0;
    while (!x.empty())
    {
      int px = x.front();
//      cout<<"px:"<<px<<endl;
      x.pop();
      if (px==b) return;
      for ( int i = 0 ;  i< k ; i++ )
      {
        if (ok(px,pri[i]))
        {
            d[pri[i]]=d[px]+1;
            x.push(pri[i]);
        }
      }
    }


}
int main()
{
     k =0;
    for ( int i = 1000; i <=9999; i++ )
    {
      if (prime(i))
      {
        pri[k++]=i;
      
      }
    }
    int T;
   // cout<<pri[0]<<endl;
   // cout<<pri[1]<<endl;
    cin>>T;
    while (T--)
    {
      cin>>a>>b;
      bfs();
      if (d[b]==-1)
      {
        cout<<"Impossible"<<endl;
      }
      else
      {
        cout<<d[b]<<endl;
      }

    }

  
    return 0;
}
原文地址:https://www.cnblogs.com/111qqz/p/4674633.html