PAT1056:Mice and Rice

1056. Mice and Rice (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

思路
有点绕的逻辑划分题,注意第三行的数据是选手的编号,索引就是选手的出场顺序,另外当前失败选手的rank = 晋级的选手数+1
代码
#include<vector>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
class rat
{
  public:
      int weight;
      int rank;
      int id;
      int order;
};


bool cmp(rat& a,rat& b)
{
    return a.id < b.id;
}
int main()
{
    int Np,Ng;
    vector<rat> rats;
    while(cin >> Np >> Ng)
    {
       vector<int> weights(Np);
       rats.resize(Np);
       for(int i = 0;i < Np;i++)
       {
           cin >> weights[i];
       }
       for(int i = 0;i < Np;i++)
       {
           cin >> rats[i].id ;
           rats[i].order = i;
           rats[i].weight = weights[rats[i].id];
       }
       queue<rat> q;
       for(int i = 0;i < Np;i++)
           q.push(rats[i]);
       while(!q.empty())
       {
           int s = q.size();
           if(s == 1)
           {
               rat tmp = q.front();
               rats[tmp.order].rank = 1;
               break;
           }
           int levels = s / Ng + (s % Ng == 0?0:1);
           rat maxrat;
           int maxn = -1,cnt = 0;
           for(int i = 0;i < s;i++)
           {
               rat tmp = q.front();
               rats[tmp.order].rank = levels + 1;
               q.pop();cnt++;
               if(tmp.weight > maxn)
               {
                   maxn = tmp.weight;
                   maxrat = tmp;
               }
               if(cnt == Ng || i == s - 1)
               {
                   cnt = 0;
                   maxn = -1;
                   q.push(maxrat);
               }
           }
       }
        sort(rats.begin(),rats.end(),cmp);
           for(int i = 0;i < Np;i++)
           {
               if(i != 0)
                cout << " ";
               cout << rats[i].rank;
           }
    }
}

  

原文地址:https://www.cnblogs.com/0kk470/p/8080764.html