PAT1037:Magic Coupon

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

 思路

  贪心算法,

  先排序,然后正数与正数相乘,负数与负数相乘就能得到最大值。

 代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

typedef long long ll;

int main()
{
   int NC,NP;
   cin >> NC;
   vector<ll> coupons(NC);
   for(int i = 0;i < NC;i++)
   {
       cin >> coupons[i];
   }
   cin >> NP;
   vector<ll> products(NP);
   for(int i = 0;i < NP;i++)
   {
       cin >> products[i];
   }
   sort(coupons.begin(),coupons.end());
   sort(products.begin(),products.end());
   int sum = 0;
   int i = 0,j = 0,lc = coupons.size() - 1,lp = products.size() - 1;
   for(;i <= lc && j <= lp;i++,j++)
   {
       if( coupons[i] <= 0 && products[j] <= 0 )
       {
           sum += coupons[i] * products[j];
       }
   }
   for(int u = lc,v = lp;u >=0 && v >=0;u--,v--)
   {
       if( coupons[u] > 0 && products[v] > 0 )
       {
           sum += coupons[u] *products[v];
       }

   }
   cout << sum << endl;
}

  

原文地址:https://www.cnblogs.com/0kk470/p/7874350.html