Pat1128:N Queens Puzzle

1128. N Queens Puzzle (20)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1, Q2, ..., QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

  
Figure 1
  
Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K <= 200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4 <= N <= 1000 and it is guaranteed that 1 <= Qi <= N for all i=1, ..., N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print "YES" in a line; or "NO" if not.

Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES

思路

N皇后问题,只不过题目仅要求判断是否是同一行和同一对角线。
对于每一个输入的数nums[i]。
1.判断是否和前面的皇后棋子是否在同一行,即输入的第i个数和前i-1个数是否相同。
2.判断是否在同意对角线上,即第i个数和前i-1个数的斜率是否相同,即abs(nums[i] - nums[k]) == abs(i - k) ( 0 <= k < i)是否成立。

代码
#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
int main()
{
   int K;
   while(cin >> K)
   {
       for(int i = 0;i < K;i++)
       {
           int N;
           cin >> N;
           vector<int> nums(N);
           bool isSolution = true;
           for(int j = 0;j < N;j++)
           {
               cin >> nums[j];
               for(int k = 0;k < j;k++)
               {
                 if(nums[k] == nums[j] || abs(nums[j] - nums[k]) == abs(j - k))
                 {
                     isSolution = false;
                     break;
                 }
               }
           }
           if(isSolution)
                cout << "YES" << endl;
               else
                cout << "NO" << endl;
       }
   }
}
原文地址:https://www.cnblogs.com/0kk470/p/7725577.html