Pat1108: Finding Average

1108. Finding Average (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路

逻辑题,注意处理下负数的情况,其余按题目要求设置好if语句的条件就行。

代码
#include<iostream>
#include<iomanip>
#include<string>
using namespace std;


bool islegal(string s)
{
    int len = s.size();
    int dotcount = 0;
    int i = 0;
    if(s[i] == '-')
    {
      if(i + 1 == len)
        return false;
      i++;
    }
    for(;i < len;i++)
    {
       if(s[i] == '.')
       {
           dotcount++;
           if(dotcount > 1)
            return false;
           if(len - 1 - i > 2)
            return false;
       }
       else if(s[i] < '0' || s[i] > '9')
         return false;
    }
    double num = stod(s);
    if(num < -1000 || num > 1000)
        return false;
    return true;
}

int main()
{
    int N;
    while(cin >> N)
    {
        string str;
        double sum = 0;
        int cnt = 0;
        for(int i = 0;i < N;i++)
        {
           cin >> str;
           if(islegal(str))
           {
               cnt++;
               sum += stod(str);
           }
           else
           {
               cout << "ERROR: " << str << " is not a legal number" << endl;
           }
        }
        if(cnt == 0)
            cout << "The average of "<< cnt <<" numbers is Undefined" << endl;
        else if(cnt == 1)
            cout << "The average of 1 number is " << fixed << setprecision(2) << sum << endl;
        else
            cout << "The average of "<< cnt <<" numbers is "<< fixed << setprecision(2) << sum/cnt << endl;
    }
}
原文地址:https://www.cnblogs.com/0kk470/p/7699891.html