PAT1065: A+B and C (64bit)

1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

思路
注意溢出的情况就行,其他情况正常比较,溢出分两种情况:
1. A > 0,B > 0, Sum = A + B 正溢出,溢出后的值Sum <= 0;
2. A < 0,B < 0, Sum = A + B 负溢出,溢出后的值Sum >= 0;

代码
#include<iostream>
#include<vector>
using namespace std;
int main()
{
    int T;
    while(cin >> T)
    {
        long long a,b,c;
        for(int i = 1; i <= T; i++)
        {
            cin >> a >> b >> c;
            long long sum = a + b;

            if(a < 0 && b < 0 && sum >= 0) //最小负数相加溢出
                cout << "Case #" << i <<": false" << endl;
            else if(a > 0 && b > 0 && sum <= 0) //最大正数相加溢出
                cout << "Case #" << i <<": true" << endl;
            else if(sum > c)
                cout << "Case #" << i <<": true" << endl;
            else
                cout << "Case #" << i <<": false" << endl;
        }
    }
    return 0;
}
原文地址:https://www.cnblogs.com/0kk470/p/7631636.html