poj_1797_dijkstra

              Heavy Transportation

Time Limit:3000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4


  题意,从1到n的所有路中,每一条都有其承载量限制,找出一条路,使得它的承载量最大,即是说,求从1到n的一条路,使得该路的最小权值在所有路中最大。


#include<cstdio>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAXN=1005;
int cost[MAXN][MAXN];
int dis[MAXN];
bool vis[MAXN];
void dijkstra(int s,int n)
{
  for(int i=1;i<=n;i++)
  {
    dis[i]=0;    //dis[i]表示到达i的路径能够通过的最大载重,那如果不能抵达,最大载重当然为0,所以初始化为0
    vis[i]=false;
  }
  dis[s]=INF;
  for(int j=1;j<=n;j++)
  {
    int p=-1;
    for(int i=1;i<=n;i++)
    if(!vis[i]&&(p==-1||dis[i]>dis[p]))
    {
      p=i;     //根据贪心,应该先选载重大的
    }
    vis[p]=true;
    for(int i=1;i<=n;i++)
    dis[i]=max(dis[i],min(dis[p],cost[p][i]));    //画出1,i,p,三点,就明白这句话了。
  }
}

int main()
{
  int test;
  scanf("%d",&test);
  for(int t=1;t<=test;t++)
  {
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
      for(int j=1;j<=n;j++)
        cost[i][j]=0;      //初始化载重为0
    for(int i=0;i<m;i++)
    {
      int u,v,w;
      scanf("%d%d%d",&u,&v,&w);
      cost[u][v]=cost[v][u]=w;
    }
    dijkstra(1,n);
    int ans=dis[n];
    printf("Scenario #%d: ",t);
    printf("%d ",ans);
  }
  return 0;
}






原文地址:https://www.cnblogs.com/-maybe/p/4257085.html