1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25分)

 

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10, 0NK​​<<N2​​<N1​​1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 3 3.6 2 6.0 1 1.6

注意系数为0的情况

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#define MAX 1000000
#define ll long long
using namespace std;
double a[10005],b[10005],c[10005];
double y;
int x;
int main()
{
    int k;
    cin>>k;
    for(int i=0;i<2006;i++)
        a[i]=b[i]=c[i]=0;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        a[x]=y;
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        b[x]=y;
    }
    for(int i=0;i<1005;i++)
    {
        for(int j=0;j<1005;j++)
            c[i+j]=c[i+j]+a[i]*b[j];//合并同类项
    }

    int cnt=0;
    for(int i=0;i<2005;i++)
    {
        if(c[i]!=0)//去除多项式系数为0的项
            cnt++;
    }
    cout<<cnt;
    for(int i=2005;i>=0;i--)
    {
        if(c[i]!=0)
            printf(" %d %.1lf",i,c[i] );
    }
    cout<<endl;
    return 0;
}
 
原文地址:https://www.cnblogs.com/-citywall123/p/12123007.html