poj 3617 Best Cow Line 贪心模拟

Best Cow Line

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 42701   Accepted: 10911

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意:输入n个大写字母组成一个字符串S,每次可以从这个字符串的队首或队尾取一个字符加到字符串T中(T初始为空),
输出字典序最小的T,当T的长度等于80时输出一个换行

#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
#include<queue>
#include<set>
using namespace std;
string s,t;
char x;
int n;
int main()
{
    cin>>n;
    int temp=n;
    while(temp--)
    {
        cin>>x;
        s=s+x;
    }
    int l=0,r=n-1,cnt=0;
    while(l<=r)
    {
        int flag=0;
        for(int i=0;i<=r-l;i++)
        {
            if(s[l+i]<s[r-i])
            {
                flag=1;//输出左边
                cnt++;
                break;
            }
            else if(s[l+i]>s[r-i])
            {
                flag=0;//输出右边
                cnt++;
                break;
            }
            else
            {
                continue;//相等,比较下一个
            }
        }
        if(flag==1)
        {
            cout<<s[l];
            l++;
        }
        else
        {
            cout<<s[r];
            r--;
        }
        if(cnt%80==0)
            cout<<endl;
    }
    cout<<endl;
    return 0;
}








原文地址:https://www.cnblogs.com/-citywall123/p/11296339.html