poj1080——lcs变形,dp

poj1080——lcs变形,dp

Human Gene Functions
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17610   Accepted: 9821

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21
题意:求两基因的相似度,先要在每个基因对中加入若干空格,然后再依次加上匹配度,详见上表,则相似度就是最大的匹配度和(语文不好,这段百度抄的。。)
lcs变种,dp[i][j]=max{dp[i-1][j-1]+sco[i][j],dp[i-1][j]+sco[s1[i]][' '],dp[i][j-1]+sco[' '][sco[s2[i]]}
上面括号内的三个式子,第一个容易理解,就不解释了,第二个,如果让s2[j]和s1[i-1]匹配,则只能在s2[j]之后补空格,让s1[i]和空格匹配,而dp[i-1][j]是已经计算好的结果,所以不用管s2[j-1]和谁匹配,这就是第二个式子,第三个式子同理
还有一点需要注意的就是初始化,dp[0][0]=0,dp[0][i]这是在是s1[0]和s2[i]匹配时在s1[0]前面补空格之后的结果,由于是第一次算而不是利用已经算出的结果,所以必须算出来,注意并不是0,
可以直接利用状态转移方程dp[0][i]=dp[0][i-1]+sco[' '][sco[s2[i]]
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>

using namespace std;

const int maxn=1010;
const int INF=(1<<28);
int T;
int n1,n2;
int s1[maxn],s2[maxn];
int sco[5][5]={
    5,-1,-2,-1,-3,
    -1,5,-3,-2,-4,
    -2,-3,5,-2,-2,
    -1,-2,-2,5,-1,
    -3,-4,-2,-1,-INF
};
int dp[maxn][maxn];
int t[maxn];

int max3(int a,int b,int c)
{
    if(b>a) a=b;
    if(c>a) a=c;
    return a;
}

int main()
{
    cin>>T;
    t['A']=0;
    t['C']=1;
    t['G']=2;
    t['T']=3;
    t[' ']=4;
    while(T--){
        char ch;
        cin>>n1;
        for(int i=1;i<=n1;i++){
            cin>>ch;
            s1[i]=t[ch];
        }
        cin>>n2;
        for(int i=1;i<=n2;i++){
            cin>>ch;
            s2[i]=t[ch];
        }
        dp[0][0]=0;
        for(int i=1;i<=n1;i++){ //注意初始化,0前面补空格才得到dp[0][i]
            dp[i][0]=dp[i-1][0]+sco[s1[i]][4];
        }
        for(int i=1;i<=n2;i++){
            dp[0][i]=dp[0][i-1]+sco[s2[i]][4];
        }
        for(int i=1;i<=n1;i++){
            for(int j=1;j<=n2;j++){
                dp[i][j]=max3(dp[i-1][j-1]+sco[s1[i]][s2[j]],dp[i-1][j]+sco[s1[i]][4],dp[i][j-1]+sco[4][s2[j]]);
            }
        }
        cout<<dp[n1][n2]<<endl;
    }
    return 0;
}
View Code


没有AC不了的题,只有不努力的ACMER!
原文地址:https://www.cnblogs.com/--560/p/4354598.html