poj1276——dp,多重背包

poj1276——dp,多重背包

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28826   Accepted: 10310

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0
题意:给若干种面值的纸币,第i种纸币有n[i]张,每张面值为D[i],问拼凑出不超过cash的最大面值是多少
思路:很明显这是一个多重背包(每种纸币的数量是有限的),用二进制优化并转化为01背包解决,如果某种纸币的可拼凑出的面值超过了cash,则看成其数量是无限的,当成完全背包处理,反之则是有限的,用二进制优化当成01背包处理
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;

const int maxn=1000100;
int cash,N;
int n[maxn],D[maxn];
int dp[maxn];

void ZeroOnePack(int weight,int val)
{
    for(int i=cash;i>=weight;i--){
        dp[i]=max(dp[i],dp[i-weight]+val);
    }
}

void CompletePack(int weight,int val)
{
    for(int i=weight;i<=cash;i++){
        dp[i]=max(dp[i],dp[i-weight]+val);
    }
}

void MultiPack(int weight,int val,int amount)
{
    if(weight*amount>=cash) CompletePack(weight,val);//如果超过限制,当完全背包处理
    else{                //否则用二进制优化并转为01背包处理
        int k=1;
        while(k<amount){//按k=1,2,4,...的顺序分解amount,对分解后的部分按01背包处理
            ZeroOnePack(k*weight,k*val);
            amount-=k;
            k*=2;
        }
        ZeroOnePack(amount*weight,amount*val); //剩下部分也按01背包处理
    }
}

int main()
{
    while(cin>>cash>>N){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=N;i++){
            cin>>n[i]>>D[i];
            MultiPack(D[i],D[i],n[i]);
        }
        cout<<dp[cash]<<endl;
    }
    return 0;
}
View Code
没有AC不了的题,只有不努力的ACMER!
原文地址:https://www.cnblogs.com/--560/p/4348716.html