洛谷P2878 [USACO07JAN]保护花朵Protecting the Flowers

题目描述

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

有n头奶牛跑到FJ的花园里去吃花儿了,它们分别在距离牛圈T分钟处吃花儿,每分钟会吃掉D朵卡哇伊的花儿,(此处有点拗口,不要在意细节啊!),FJ现在要将它们给弄回牛圈,但是他每次只能弄一头回去,来回用时总共为2*T分钟,在这段时间内,其它的奶牛会继续吃FJ卡哇伊的花儿,速度保持不变,当然正在被赶回牛圈的奶牛就没口福了!现在要求以一种最棒的方法来尽可能的减少花儿的损失数量,求奶牛吃掉花儿的最少朵数!

输入输出格式

输入格式:

 

Line 1: A single integer N

Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

 

输出格式:

 

Line 1: A single integer that is the minimum number of destroyed flowers

 

输入输出样例

输入样例#1:
6
3 1
2 5
2 3
3 2
4 1
1 6
输出样例#1:
86

说明

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.

题目大意:n头牛吃草,每头牛有每分钟吃多少草,把这头牛运走需要多少时间,求怎样运牛,使牛吃更少的草。

题解:根据每分钟吃的花和运输时间的比值从大到小运...

 如果先运j,i牛产生的贡献是cow[i].d*cow[j].t,如果先运i,j牛产生的贡献是cow[j].d*cow[i].t

假设前者比后者小,则,cow[i].d*cow[j].t<cow[j].d*cow[i].t,那么先运j更优,

更优的条件是,cow[i].d/cow[i].t<cow[j].d/cow[j].t为贪心的公式

代码:

#include<iostream>
#include<cstdio>
#include<cstdio>
#include<algorithm>
using namespace std;

int sum,n;
long long ans;

struct COW{
    int t,d;
}cow[100008];

bool cmp(COW a,COW b){
    return a.d*1.0 /a.t>b.d*1.0 /b.t;
}

int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
      scanf("%d%d",&cow[i].t,&cow[i].d),sum+=cow[i].d;
    sort(cow+1,cow+n+1,cmp);
//    for(int i=1;i<=n;i++)cout<<cow[i].d<<endl;
    for(int i=1;i<=n;i++){
        sum-=cow[i].d;
        ans+=sum*cow[i].t*2;
    }
    cout<<ans<<endl;
    return 0;
}
原文地址:https://www.cnblogs.com/zzyh/p/7605824.html